Volkszone Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
244 Posts
Discussion Starter · #1 ·
When the car is running with no lights on its fine, but as soon as i try and run any power from anything electrical the engine will struggle or stall. The red dash light is on and goes bright when i rev the engine.
It doesnt seem to be charging the battery. The regulator is new and there looks to be contact in the dynamo. I've fitted a new fan belt as the other one was slipping, but that hasnt made any difference. I could be wired incorect as i didnt fit it, the last owner did.
Once i turn the car off it wont star again under its own steam, but if i run jump leads to it it will start perfect and run fine once the leads are taken off, untill i try and turn the lights on or use the wipers.

Help please :)
 

·
Registered
Joined
·
244 Posts
Discussion Starter · #3 ·
Cheers Jim, i've used your guide to test the generator and it seems to be working fine (very helpful :) ).
I've checked all the wiring and that also seems to be fine.

The battery is holding 11.3 volts of charge when its not running, but as soon as i start the engine the volt metre goes mad. The readings are all over the place. I changed the earth on the battery, but still no difference.

Any ideas??? Its driving me nuts.
 

·
Registered
Joined
·
18,482 Posts
Are the "mad" readings all above 11.3V ?

When revving, the battery should read about 14V (rough).

The erratic readings suggest a flaky regulator or, possibly,
Dynamo brushes making poor contact.
 

·
Registered
Joined
·
244 Posts
Discussion Starter · #5 ·
The readings are so mad i cant even read what its doing. I've tried pushing the contacts in on the generator, but makes no difference.
I'm guessing its the regulator, so 'ill buy a new one tomorrow and try that.
 

·
Registered
Joined
·
18,482 Posts
I had a '56 Ghia (long story) but I don't recall where
the battery was or the earth point :rolleyes:
It really doesn't matter as long as the connection is solid.
If yours wasn't solid, the starter wouldn't be working.
 
1 - 7 of 7 Posts
Top