Volkszone Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
224 Posts
Discussion Starter · #1 ·
Hello there,

My Mexican bug's drivers side lock is sticking. He's ok to lock, but unlocking and it's really stiff. This morning it wouldn't open and I had to use the other side. I had central locking fitted about 4/5 months ago.

Would a blast of plus-gas or WD40 into the mechanism work? I need a quickish fix as he's my daily drive and use him at work when I go out.


I rebuilt the locks on my bay a few years ago and greased them up no end I wonder if these need the same grease treatment?

Thanks in advance :group:
 

·
Registered
Joined
·
224 Posts
Discussion Starter · #3 ·
Hi Al, thanks for the info. The central locking was fitted professionally, so may mention to him.

Reckon WD40 or the like would help in the interim?

Probably have to grease it up when I get chance, but I've got another 4 days of use to get through. Why does it always happen on a Monday?
 

·
Registered
Joined
·
8,833 Posts
Monday morning is part of the fun of running a classic as a daily!

I think WD40 or the like would be worth a try, though not too much. Maybe have a little squirt at the mechanism with the door open too.

Is it hard to open from the inside too, or just from the lock? That might ascertain where the problem lies. I've had a sticky lock once, but I wouldn't like to think a late Mex should have this problem so soon. I'd leaning towards to central locking being the issue if I'm honest.
 

·
Registered
Joined
·
224 Posts
Discussion Starter · #5 ·
I wondered about it being the central locking. Opening is fine from inside, a little sticky from outside, and I've had a squirt, but as you say only a little. I didn't get chance to check it there and then as I'm having to watch for flood water. Locking did seem better though, so am hopeful.

Report tomorrow once I've opened him again......

Thanks for the advice.
 
1 - 5 of 5 Posts
Top